[Django]-Weird error with – python manage.py runserver (Exception in thread django-main-thread)

4👍

Higher in traceback, there is a line

ModuleNotFoundError: No module named 'webjournalsusers'

If you try and look higher then that, there are several lines which mention INSTALLED_APPS and their “population” (e.g. installing them). So, what happens is: Django tries to install each app, but when it sees app with name webjournalsusers, it can’t import it.

The same error will happen if you will try to add an app as random characters in clean django project.

So, you either wrote the name of the app in INSTALLED_APPS wrong, or the app doesn’t exist in the directory django is searching for it (usually core directory of the project, if this app is written by you, and not installed by pip).

0👍

U just need to type this in cmd(visual studio code or ordinary cmd):
pip install django-cors-headers.

This solved the problem for me. 🙂

0👍

In "apps.py":
class ErpConfig(AppConfig):

default = False

Leave a comment