[Fixed]-Heroku Upload – Could not find a version that satisfies the requirement anaconda-client==1.4.0

14👍

For every message

No matching distribution found for X

that you get, you have to manually do:

1 – at the line of requirements.txt where X appears, remove ==<version number>
2 – save the file
3 – commit
4 – push

do it again for the next error reported by the prompt, until you reach the end of the list cointained in requirements.txt.

(In case your X is psycopg2, substitute it with psycopg2-binary).


The same result can be achieved by installing and running pip-chill

pip install pip_chill
pip-chill --no-version > requirements.txt

Note: this is a last-resource solution, so, before implementing it, see if you can solve the problem by following the instructions of this answer

👤Tms91

7👍

Have you created environment in the conda ?

If so, after you activate the env. you need to conda install pip to activate pip install, otherwise your pip freeze would go back to the default anaconda environment. (thats why you are seeing them there)

  1. conda install pip
  2. pip install all the available packages again. (e.g. pip install django)
  3. pip freeze > requirements.txt

Please see myth 5 below
https://jakevdp.github.io/blog/2016/08/25/conda-myths-and-misconceptions/

2👍

The solution for this error is pretty simple:

  1. I hope you already have created requirements.txt file in your app folder, you ran pip > freeze command and made a commit and pushed.

When you do that pip can also automatically add modules to the file, Pip can also install a dependency from your local codebase automatically. That can be a problem.

  1. Simply go to your requirement.txt file and look for anaconda-client==1.4.0 (or error starting with “No matching distribution found for” a module) and remove it from the file.

  2. Save the file, commit and push.

I had the similar problem and error with conda and i took the same steps and it worked for me.

I hope it helps some of you guys.

2👍

The error is possibly caused by the fact that Anaconda libraries have changed and the version 1.4.0 and the others have been removed, so that they no longer exist.

Some of these are:

anaconda-client==1.7.2
anaconda-navigator==1.9.7
anaconda-project==0.8.2
blaze==0.11.3    
clyent==1.2.2    
conda==4.9.2
conda-build==3.20.5
conda-package-handling==1.3.11
...

(==removed versions)

Try to fix the problem by just updating all the libraries in your environment:

conda update -n base conda
conda update --all

then

pip freeze>requirements.txt
git add .
git commit -m "something"
git push heroku master
👤Tms91

1👍

According to PyPI, there’s no such thing as anaconda-client version 1.4.0: the highest version is 1.2.2.

0👍

Could not find a version that satisfies the requirement 
anaconda-client==1.4.0 (from -r 
/tmp/build_a1f6d188f9e0e61e01076a73d4e10542/requirements.txt (line 2))
(from  versions: 1.1.1, 1.2.2)

Hello,
It may be too late, yet helpful for someone else. I got the same issue (but with a different package), and here is what I did (and it works!)

The package was a must for my project, so I could not remove it

  • replaced my package version with the available ones in requirments.txt which in your case is 1.1.1 or 1.2.2
  • then git heroku master
👤Hagar

Leave a comment