[Fixed]-Mac pip install mysql-python unsuccessful

13👍

Please, try:

CFLAGS=-Qunused-arguments CPPFLAGS=-Qunused-arguments pip install -r requirements.txt

If it does not work:
First install mysql-connector-c

brew install mysql-connector-c 
pip install MySQL-python

If you are using Windows:

https://dev.mysql.com/downloads/connector/c/

You can also check what happend when you try install it with pip3.

UPDATE:
If you have Linux:
Please open the /usr/local/bin/mysql_config.

And then:

#Create options
Libs = "-L $ pkglibdir "
Libs = " $ libs   -l"

replace with:

#Create options
Libs = "- L $ pkglibdir"
Libs = "$ libs -lmysqlclient -lssl -lcrypto"

Save it and reinstall mysql-python.

pip uninstall mysql-python
pip install mysql-python

For Mac:

LDFLAGS=-L/usr/local/opt/openssl/lib pip install mysql-python

should be helpful.

39👍

Installing of an older version of the MySQL worked for me:

brew remove mysql
brew install mysql@5.7
brew link --force mysql@5.7
pip install mysql-python

See:

4👍

brew install mysql@5.7
export PATH="/usr/local/Cellar/mysql@5.7/5.7.29/bin:$PATH"
export LDFLAGS="-L/usr/local/Cellar/mysql@5.7/5.7.29/lib -L/usr/local/Cellar/openssl@1.1/1.1.1d/lib"
export CPPFLAGS="-I/usr/local/Cellar/mysql@5.7/5.7.29/include -I/usr/local/Cellar/openssl@1.1/1.1.1d/include"
/Users/tivanli/source/bk_project/pizza/venv/bin/pip install MySQL-python==1.2.5

0👍

For me it was:

brew install mysql-connector-c 
pip install MySQL-python
pip install mysql-connector

0👍

Those who are facing this issue on Ubuntu even after installing all the required packages. They can follow this

  • Copy the Source for my_config.h from official url-

https://dev.mysql.com/doc/dev/mysql-server/8.0.11/my__config_8h_source.html

Then create a file in /usr/include/my_config.h and paste it

sudo nano /usr/include/my_config.h

you can paste the content using ctrl + shift + v, depending on your distribution.

Now install the package, your version or no version.

 pip install mysqlclient==1.3.7

You can get the source of the file from official link depending upon the SQL version.

Original Linkhttp://www.kombitz.com/2020/04/29/my_config-h-no-such-file-or-directory-on-centos-8/

-3👍

Just uninstall your Mysql, and install MySql 5.7
and is fixed!!!!

If you are not successful from any of the above solutions, it means that your MySql version is not matching the requirements. i was thinking that it is because of Python or PyCharm, and i used virtualenv and conda but no luck, so when i compared my dependencies to one of my friend’s computer, it was MySql version. downgraded to 5.7 and its working fine.

Leave a comment